Elevated GIT/Application Builder Errors
Incident Report for Balena.io
Postmortem

A version of our cloud builder API was deployed that changed some variable types and did not properly report the build ID back to balena CLI when using the push command with release tags.

We identified the issue and rolled back the release in production while we work on a fix.

Posted Jan 03, 2024 - 18:11 UTC

Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 17:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 03, 2024 - 16:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 03, 2024 - 16:17 UTC
Investigating
We're experiencing an elevated level of errors in our application builder infrastructure and are currently looking into the issue.
Posted Jan 03, 2024 - 15:54 UTC
This incident affected: Application Builder.