An upstream provider outage is affecting connectivity to balenaCloud services

Incident Report for balena.io

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:37 UTC

Monitoring

Our upstream provider has implemented some fixes. balenaCloud services are back online. We are still monitoring the situation.
Posted Dec 05, 2025 - 09:16 UTC

Identified

CloudFlare, our proxy provider, is having service issues. Connectivity to balenaCloud services are currently affected.
Posted Dec 05, 2025 - 09:05 UTC
This incident affected: API, Dashboard, and Website.