Device settings undefined property reference
Incident Report for Balena.io
Postmortem

We've identified and are addressing an issue on the device settings page caused by re-fetching the selected device and receiving it as undefined during the first few renders, despite already having information about it. We have addressed the issue by using the the information we already have about the device when on the device settings page, instead of attempting to re-fetch it.

Posted Mar 21, 2024 - 16:54 UTC

Resolved
Balena Dashboard device settings show an `undefined` property reference.
`TypeError: Cannot read properties of undefined (reading 'reduce')`
Posted Mar 21, 2024 - 13:00 UTC