Elevated Dashboard Errors
Incident Report for Balena.io
Postmortem

We pushed a change intended to migrate the Download Image Dialog from rendition to MUI as we are in the process of migrating between UI libraries. This involved adding some analytics/tracking content in the Download Image Dialog.

This added cookies, which in conjunction with how we checked cookies inadvertently created an infinite loop when checking cookies.

The quick solution while a fix was worked on was to pin the dashboard back to the previous version. A solution has been PRed and is aimed to be merged tomorrow when the team has more time to monitor the situation.

Posted Dec 14, 2023 - 14:14 UTC

Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 18:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2023 - 17:26 UTC
Investigating
We're experiencing an elevated level of errors on our Dashboard and are currently looking into the issue.
Posted Dec 13, 2023 - 17:09 UTC
This incident affected: Dashboard.