Web Terminal SSH Errors
Incident Report for Balena.io
Postmortem

The service handling the web-socket connection for the web terminal silently failed. Restarting the service fixed the issue.

While we’re investigating the root cause, we added some checks to ensure the service is restarted quickly if the web-socket server is not responsive.

Posted Aug 10, 2023 - 15:28 UTC

Resolved
The web-terminal on the dashboard is now back to a fully working state.
Posted Jul 31, 2023 - 08:06 UTC
Monitoring
Dashboard Web Terminal is now available again and we're monitoring the situation.
Posted Jul 31, 2023 - 07:30 UTC
Investigating
We're experiencing some disruption with the web terminal SSH access on the dashboard.
Note that SSH access using the CLI is still working ( `$ balena ssh *deviceuuid*` )
We are currently looking into the issue.
Posted Jul 31, 2023 - 07:17 UTC
This incident affected: Dashboard.