Degraded cloudlink connection performance

Incident Report for balena.io

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 00:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 22, 2025 - 00:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2025 - 00:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 22, 2025 - 00:10 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 22, 2025 - 00:10 UTC
This incident affected: Device URLs and Cloudlink (VPN).