Unable to pin releases in the dashboard

Incident Report for balena.io

Postmortem

A UI update included updates to a few nested dependencies, which changed a behavior we relied on. The result was preventing the data population of available releases in the Target Release section on the Fleet Summary page.
We initially reverted the changed package, and subsequently changed our approach so that it works with the latest version of the package.

Posted Apr 14, 2025 - 12:52 UTC

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 14:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2025 - 13:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2025 - 13:00 UTC

Investigating

We are currently investigating an issue with users unable to pin releases in the dashboard.
Posted Apr 10, 2025 - 13:00 UTC
This incident affected: Dashboard.