WebTerminal connectivity unavailable
Incident Report for Balena.io
Postmortem

As part of refactoring balenaCloud configuration assets, one of the components restarted without a configuration variable pointing to the balena device proxy. As a result the WebTerminal connectivity was being initialised with a malformed URL, resulting in inability to establish a socket connection to the proxy.

After troubleshooting, the missing environment variable was remapped in the configuration and the API/dashboard components restarted for it to take effect. WebTerminal connectivity was tested and found to be working.

Posted Jul 21, 2021 - 01:25 UTC

Resolved
WebTerminal and related functionality such as device diagnostics we unavailable due to a component miss-configuration.
Posted Jul 21, 2021 - 01:00 UTC