Premium Support Portal outage
Incident Report for balena.io
Resolved
Our premium support portal is now fully functional again
Posted Mar 29, 2023 - 15:51 UTC
Investigating
Our Premium Support is currently unavailable.
Access to Zendesk Help Center return a "This page doesn't exist" error.

If you're in need of assistance, please use the live chat functionality from the dashboard.
Posted Mar 29, 2023 - 15:39 UTC
This incident affected: Support (Zendesk).