Device HostOS and Supervisor Updates Unavailable
Incident Report for Balena.io
Postmortem

After receiving reports from the community and doing an investigation, we found that the balena proxy restarted without a configuration variable pointing to the balena image registry. The configuration was missing when the proxy was reloaded after a refactoring of the balenaCloud configuration assets.

The proxy has been restarted to reload the missing configuration. HostOS and supervisor updates are working again.

Posted Jul 21, 2021 - 14:21 UTC

Resolved
Since July 20, 2021 19:00 UTC, attempts to update the hostOS and supervisor were failing.
Posted Jul 21, 2021 - 12:00 UTC