VPN Degraded Performance
Incident Report for Balena.io
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 18:44 UTC
Monitoring
Devices have been reconnecting rapidly and we expect the service to be fully operational again.
Posted Jun 21, 2022 - 18:23 UTC
Update
Scaling up readers caused some readers to be unavailable for handling devices reconnecting which introduced more degraded performance. Readers are now all scaled up though and we expect systems to begin to recover shortly.
Posted Jun 21, 2022 - 17:37 UTC
Identified
The cause of disconnections is unclear but we believe the fleets reconnecting is degrading the database performance causing further degraded performance since queries take longer to process. Readers are scaling up to mitigate this.
Posted Jun 21, 2022 - 17:02 UTC
Investigating
Monitoring instances of devices disconnecting from our VPN. Current situation shows fleets are reconnecting.
Posted Jun 21, 2022 - 16:56 UTC
This incident affected: Cloudlink (VPN).