Elevated Device SSH Errors
Incident Report for balena.io
Postmortem

There was a brief outage of remote SSH access to devices while we rotated some access keys in our cluster. Going forward we will adapt our process to avoid the downtime, or include it as part of planned maintenance windows.

Posted Oct 18, 2024 - 21:20 UTC

Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 21:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2024 - 21:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2024 - 21:07 UTC
Investigating
We're experiencing an elevated level of device SSH errors and are currently looking into the issue.
Posted Oct 18, 2024 - 20:57 UTC
This incident affected: Git and Cloudlink (VPN).