Elevated Device SSH Errors

Incident Report for balena.io

Postmortem

On February 26, 2026 at approximately 19:00 UTC, users began experiencing failures when connecting to their devices via balena device ssh. The command returned a generic "host error" with no further detail. The issue affected all CLI-based SSH access through the balena proxy.

Web terminal access and balena device tunnel remained functional throughout the incident and were available as workarounds. Devices themselves were online and healthy; the failure occurred at the authentication stage between the proxy and the device.

Root cause

The balena proxy runs several internal processes. As a resource-saving measure, the service that handles web terminal connections had been disabled in the proxy pods dedicated to CLI SSH, since those pods do not serve web terminal sessions. What was not recognized at the time was that this service also carried the responsibility for loading SSH identity keys into the shared SSH agent used by the proxy. With it disabled, the proxy pods had no keys loaded and could not authenticate with devices, causing every SSH connection attempt to fail at the authentication stage.

Resolution

The service that handles web terminal connections was temporarily re-enabled in the SSH proxy pods while a permanent fix was being developed, restoring SSH key availability and resolving the authentication failures. A permanent fix has since been deployed.

Follow-up

We have decoupled the SSH key loading from the service that handles web terminal connections so that it is an independent initialization process in the proxy. We also added additional monitoring to ensure that SSH access through the proxy is adequately checked.

We sincerely apologize for the impact this caused. We are committed to improving our processes to prevent issues like these.

Posted Mar 17, 2026 - 12:03 UTC

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 03:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 03:02 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 27, 2026 - 02:41 UTC

Update

We are continuing to investigate this issue.
It only affects the direct SSH to device connection for example established via the balena-cli with balena device ssh . Web Terminal via the dashboard and standard tunnelling is not affected.
Posted Feb 26, 2026 - 21:13 UTC

Investigating

We're experiencing an elevated level of device SSH errors and are currently looking into the issue.
Posted Feb 26, 2026 - 19:20 UTC
This incident affected: SSH proxy.