Elevated Cloudlink Errors

Incident Report for balena.io

Postmortem

Balena devices were unable to connect to Cloudlink on February 10, 2026, from approximately 02:26 GMT to 07:11 GMT due to an expired server certificate. Devices that were already connected to Cloudlink were unaffected unless the connection was terminated.

Root Cause: The Cloudlink servers were using an expired certificate that was due for replacement. Consequently, incoming Cloudlink connections failed with a certificate verification error.

Resolution: The certificate has been replaced, and Cloudlink servers were restarted to use the new certificate. Balena devices are expected to reconnect to Cloudlink within a few minutes after being disconnected due to the restart.

Follow-up Actions:

  • Expand certificate expiry monitoring coverage to include all active certificates
  • Automate the certificate renewal process for Cloudlink

We apologize for any disruption this caused and appreciate your patience as we continue improving our processes and operations.

Posted Feb 10, 2026 - 12:04 UTC

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 07:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 07:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 10, 2026 - 06:39 UTC

Investigating

We're experiencing an elevated level of errors in our Cloudlink infrastructure and are currently looking into the issue.
Posted Feb 10, 2026 - 04:05 UTC
This incident affected: Cloudlink (VPN).