We experienced degraded API performance due to an internal configuration change that unintentionally increased system load, resulting in slower response times and reduced request capacity. Our team identified the issue and rolled back the change to restore stability. A root cause fix has been implemented and deployed aswell. The system has now fully recovered, and services are operating normally.
Posted Mar 25, 2026 - 14:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 24, 2026 - 13:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 12:58 UTC
Identified
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Mar 24, 2026 - 12:43 UTC
This incident affected: API, Application Builder, Application Registry, Dashboard, Delta Image Downloads, Device URLs, Git, and Cloudlink (VPN).