Elevated API Log Errors

Incident Report for balena.io

Postmortem

We deployed an upgrade to our log system that worked well in staging, but in production hit issues with log streams so we quickly rolled it back.

We have identified the issue and why it only affected one environment, and are investigating an alternate solution going forward.

Posted Feb 06, 2025 - 19:29 UTC

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 13:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 05, 2025 - 17:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2025 - 17:53 UTC

Investigating

We're experiencing an elevated level of log stream errors and are currently looking into the issue.
Posted Feb 05, 2025 - 16:45 UTC
This incident affected: API and Dashboard.