Degraded Performance

Incident Report for balena.io

Resolved

Insufficient AWS compute capacity overloaded the remaining nodes. This high load caused readiness probes to fail, triggering API restarts that created a feedback loop of increasing pressure.
Posted Dec 24, 2025 - 09:38 UTC

Monitoring

Scaling issues during service deployment caused by unavailability of nodes from underlying scaling provider.
Posted Dec 23, 2025 - 19:03 UTC

Investigating

We are currently investigating an issue affecting the availability of balenaCloud services.
Posted Dec 23, 2025 - 16:32 UTC
This incident affected: API, Application Builder, and balenahub.