Elevated Device URLs/VPN Errors
Incident Report for Balena.io
Postmortem

A routine infrastructure maintenance caused most devices to disconnect from the VPN. It took a while for the backend to accommodate all reconnection requests from these devices.

We are looking for ways to minimize the impact of system maintenance on the availability of the balenaCloud features. Occasional VPN disconnections are unavoidable when we redirect the traffic to upgraded infrastructure or to updated VPN backend services.

Posted Jun 07, 2022 - 14:28 UTC

Resolved
This incident has been resolved.
Posted Jun 07, 2022 - 14:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2022 - 13:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 07, 2022 - 13:16 UTC
Update
We are continuing to investigate this issue.
Posted Jun 07, 2022 - 13:00 UTC
Investigating
We're experiencing an elevated level of errors in our Device URLs and VPN infrastructure and are currently looking into the issue.
Posted Jun 07, 2022 - 12:55 UTC
This incident affected: Cloudlink (VPN).