Elevated Device URLs/VPN Errors

Incident Report for balena.io

Postmortem

We were notified of an issue with memory consumption on some of the Cloudlink pods in our cluster on Sunday.

We were able to redeploy the pods while we investigated the root cause. There should have been little or no interruption of service while the new pods came online and the old ones were slowly drained.

We have since implemented one improvement to avoid memory consumption issues, and are looking into other possible root causes.

Posted May 20, 2025 - 18:28 UTC

Resolved

This incident has been resolved.
Posted May 18, 2025 - 16:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2025 - 13:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 18, 2025 - 13:26 UTC

Investigating

We're experiencing an elevated level of errors in our Device URLs and VPN infrastructure and are currently looking into the issue.
Posted May 18, 2025 - 13:13 UTC
This incident affected: Cloudlink (VPN).