Elevated Error on Public Device Url

Incident Report for balena.io

Resolved

Unusual load on the proxy, caused some degraded performances on the device URL.
Everything is now working properly.
Posted Jul 27, 2026 - 18:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2026 - 17:06 UTC

Update

We are continuing to investigate this issue.
Posted Jul 27, 2026 - 17:06 UTC

Investigating

We're currently seeing some Gateway error on public device url.
Investigation ongoing.
Posted Jul 27, 2026 - 16:49 UTC
This incident affected: Device URLs.