Degraded cloudlink connection performance

Incident Report for balena.io

Resolved

Cloudlink connections are all stable and all old connections have been drained and reestablished
Posted Mar 20, 2025 - 20:54 UTC

Monitoring

We cycled the cloudlink deployment and monitor the connections recovering.
Posted Mar 20, 2025 - 20:20 UTC

Identified

Internal connection metrics collector failed to report properly to connection monitoring.
Posted Mar 20, 2025 - 20:20 UTC

Update

We are currently investigating the cause of connection drops on out cloudlink services.
Posted Mar 20, 2025 - 18:13 UTC

Investigating

Extended connection drops over period of time
Posted Mar 20, 2025 - 15:00 UTC
This incident affected: Cloudlink (VPN).