Elevated Delta Errors

Incident Report for balena.io

Postmortem

v2 delta generation service experienced failures from ~21:15 UTC Feb 9 to ~10:00 UTC Feb 10, 2026, due to a missing configuration dependency during a logic change.

Impact:

  • v2 delta generation requests failed to complete
  • No data loss or security impact

Root Cause: Recent logic changes were deployed without the required accompanying configuration update, preventing the service from completing v2 delta requests.

Resolution: The logic changes were rolled back, restoring the service to its previous stable state.

Follow-up Actions:

  • Prepare and deploy the permanent fix

We apologize for the disruption and any inconvenience this caused. We are committed to improving our processes to prevent similar issues in the future.

Posted Feb 11, 2026 - 00:35 UTC

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 00:02 UTC

Monitoring

We have identified the potential cause and have rolled back the changes.
Posted Feb 10, 2026 - 10:25 UTC

Investigating

Some delta generation requests are encountering errors and failing. We are currently investigating this issue.
Posted Feb 10, 2026 - 09:33 UTC
This incident affected: Delta Image Downloads.