Elevated error rate on ARM Native builds
Incident Report for Balena.io
Postmortem

An over-sized build job resulted in low free space on one of the native builders (arm03). Some user builds scheduled on this builder encountered failures due to lack of free space. The issue was resolved as failing healthchecks diverted incoming build jobs to other nodes, until the allocated disk space was garbage collected. We ll be working on further improving our healthchecks and limits on our native builder instances.

Posted Oct 11, 2019 - 08:51 UTC

Resolved
An elevated error rate on ARM native builds was encountered, due to capacity issues on `arm03` while marked as active on the native builders pool.
Posted Oct 09, 2019 - 15:55 UTC