Elevated Device URLs/VPN Errors
Incident Report for Balena.io
Postmortem

We’ve noticed intermittent timeout of the VPN endpoint, which affected device URL and related functionality.

We’ve identified the potential cause with health check timeouts being set too low on the backend and implemented a fix to increase these to match the entire health check timeout chain.

We are now monitoring VPN stability.

Posted Jan 26, 2021 - 16:33 UTC

Resolved
We're experiencing an elevated level of errors in our Device URLs and VPN infrastructure and are currently looking into the issue.
Posted Jan 26, 2021 - 19:00 UTC