Device Logging Impaired
Incident Report for Balena.io
Resolved
This incident has been resolved.
Posted Nov 21, 2021 - 10:22 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2021 - 10:15 UTC
Update
We are applying some configuration to our database to improve replication performance.
Posted Nov 21, 2021 - 09:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2021 - 08:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2021 - 08:09 UTC
Update
We see that our read-replica database has lagged considerably behind master. We are continuing to investigate the issue. Some API requests may fail. Application builds may also fail because of API response timeouts.
Posted Nov 21, 2021 - 07:42 UTC
Investigating
We are currently investigating an issue in which the dashboard is not displaying device logs.
Posted Nov 21, 2021 - 07:09 UTC
This incident affected: API, Application Builder, and Dashboard.